30 Jan 2017

Unverträglich? Surface, aktueller LAN-Treiber und Virtualisierung

Maik von Dr. Windows hat mich auf ein Problem aufmerksam gemacht, welches zumindest bei der Kombination Surface Pro 4 / Surface Book, deren aktuellem LAN-Treiber und dem Einsatz von Virtualisierungslösungen auftritt. Sowohl mit VMware als auch Hyper-V tritt bei Nutzung des LAN-Treibers (über das Surface Dock) ein Blue-Screen (BSoD) auf, wenn das Surface in den Standby wechselt bzw. aus diesem wieder geweckt wird.

Maik hatte mich hierzu bereits vor ca. 2 Wochen angeschrieben und um Unterstützung gebeten. Zur Analyse hat er mir die aktuellen Treiberstände sowie Dump-Files des BSoD in Form von sogenannten Mini-Dumps zur Verfügung gestellt. Eine Schnellanalyse der Dumps hat dann gezeigt, dass der auftretende BSoD mit dem Code “9F” bei der Reaktivierung in Verbindung mit dem Microsoft-Treiber des IP-Stacks (TCPIP.SYS) steht. Da ich nicht glaubte, dass wirklich der Treiber das Problem auslöst hatte ich die Ursache in einer der folgenden Komponenten vermutet:

  • LAN-Treiber
  • VMware

Entsprechend habe ich Maik gebeten diese beiden Quellen auszuschließen. Wie Maik da vorgegangen ist und was er herausgefunden hat wurde heute von ihm auf Dr. Windows in seinem Artikel Surface: Problem mit dem neuesten LAN-Treiber und Virtualisierung beschrieben.

Zusammenfassend gab es zwei Lösungen:

  1. den aktuell veröffentlichten LAN-Treiber durch dessen Vorgängerversion ersetzen
  2. VMware deinstallieren

Da Maik jedoch einen Virtualisierer benötigt habe ich ihn gefragt, warum er nicht Hyper-V und damit Bordmittel einsetzt. Hat er dann auch gemacht – leider mit gleichem Ergebnis!

Maik zieht daraus den nachvollziehbaren Schluss, dass es sich um ein generelles Problem des LAN-Treibers handeln muss, denn das Problem tritt sowohl auf dem SP4 als auch dem Book unabhängig vom eingesetzten Hypervisor auf. In beiden Fällen lässt sich das Problem durch Herabstufen des LAN-Treibers lösen.

So wie es aussieht hat sich also in der letzten Treiberversion ein Fehler eingeschlichen, der zum beschriebenen Verhalten führt, nämlich einem BlueScreen mit dem Bugcheckcode “9F”.
Ralf wird dieses Problem und die gesammelten Erkenntnisse an Microsoft weitergeben, wir werden über daraus resultierende Erkenntnisse berichten.

Bis zur Lösung des Problems empfehlen wir bei Nutzung der beschriebenen Konstellation auf den vorhergehenden Treiber zurückzugehen. Dies kann im Gerätemanager durch Auswahl des Treibers, Rechtsklick und Auswahl von “Einstellungen” wie folgt dargestellt erreicht werden:

Anmerkung: der Screenshot stammt von meinem Surface Pro 3, der problembehaftete Treiber weist folgende Treiberdaten auf:

Anmerkung zum Schluss:

Ob das Problem auch mit VirtualBox auftritt konnte bis zur Erstellung dieses Artikels nicht in Erfahrung gebracht werden. Aber vielleicht kann uns einer unserer Leser hierzu eine Information zukommen lassen. Ebenso wenig ist uns bekannt, ob auch andere Geräte wie z.B. das Surface Pro 3 betroffen sind (ich nutze keinen Hypervisor auf dem Device).

Natürlich sind wir auch auf eure Erfahrungen gespannt um zu erfahren, ob ihr die gleichen Erfahrungen gemacht habt.

Über den Autor: Thomas Paatsch

Thomas Paatsch
Wie auch Ralf bin ich ein Fan der Surface Produktfamilie und bin neben ihm hier einer der Hauptverfasser von Artikeln zu diesem Themengebiet. Nach einem Ausflug zur Konkurrenz (Toshiba Portégé) bin ich mittlerweile ins Surface Lager zurückgekehrt und heiße ein Surface Pro 6 mein Eigen. In meinem Haushalt gibt es aber auch noch einen Surface Laptop 1.